La fonction NB.SI dans Excel

La fonction NB.SI dans Excel
Dernière mise à jour le 24/04/2024
Temps de lecture : 3 minutes

La fonction NB.SI d'accel permet de dénombrer, ou de compter, le nombre de lignes correspondant à un critère (un nom, un code produit, une référence, ...). Cette fonction fait partie des 10 fonctions à connaître absolument dans Excel.

Comment utiliser la fonction NB SI ?


La fonction NB.SI d'Excel se compose de 2 arguments

  1. La plage de données contenant le critère recherché

    Il vous suffit de sélectionner l'ensemble des données de la colonne

  2. Le critère à rechercher

    Il peut s'agir soit d'une valeur entrée directement dans la formule, soit d'une référence à une cellule.

=NB.SI(plage de données; critère)

Comment utiliser la fonction NB SI ?

Nous allons partir de ce tableau qui présente les quantités vendues de produit par nos vendeurs

Presentation de la fonction NB.SI Excel

Nous voulons savoir combien de fois nous avons vendu de Kiwi ?

Vous pourriez compter les lignes qui contiennent le mot "Kiwi" mais ça serait bien trop long surtout si vous avez plusieurs centaines de ligne. C'est justement dans cette situation qu'il faut utiliser la fonction NB.SI.

  1. Ecrivez dans une cellule le nom de la fonction =NB.SI(
  2. Puis indiquez la plage de cellules (les références de la colonne) où se trouve le mot Kiwi. Dans notre cas, c'est la colonne B
  3. Enfin, indiquez le critère à rechercher, soit le mot "Kiwi". Le mot est à mettre entre guillemet quand il s'agit de texte.

=NB.SI(B2:B12;"Kiwi") => 4

Fonction NB.SI pour compter le nombre de ligne avec un critere fixe

Vous voyez, c'est tout simple !

Utiliser des références de cellules

Maintenant, nous pouvons encore plus nous simplifier le travail. Plutôt que d'écrire le mot directement dans la formule, nous pouvons utiliser le même mot mais écrit dans une cellule. Par exemple, Je vais écrire le mot "Kiwi" dans la cellule F2 et donc ma formule va s'écrire :

=NB.SI(B2:B12;F2) => 4

Fonction NB.SI en utilisant la reference dune cellule

Remarque : Quand il s'agit de référence à une cellule, il ne faut pas mettre de guillemet.

L'avantage de cette technique c'est qu'il vous suffit de changer le nom du produit à rechercher en F2 pour effectuer un dénombrement sur un autre produit. Comme par exemple en écrivant le mot "Poire"

Modification du nom du critere de denombrement
  • La formule n'a pas été modifiée
  • Seul de critère à dénombrer a été changer en F2
  • Cette fois, nous avons dénombré 3 fois le mot Poire dans notre tableau de produit.

Et comment écrire la fonction NB.SI pour les prénoms?

Si maintenant nous voulons savoir combien de fois le vendeur "Bernard" a effectué de vente, il faut modifier la plage de critère de recherche. Dans ce cas, il faut changer le premier paramètre de la fonction pour indiquer la colonne A.

=NB.SI(A2:A12;F2)

Pour un denombrement sur les prenoms il faut changer la plage de critere

Article liés

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

La fonction NB.SI dans Excel

Reading time: 3 minutes
Dernière mise à jour le 24/04/2024

La fonction NB.SI d'accel permet de dénombrer, ou de compter, le nombre de lignes correspondant à un critère (un nom, un code produit, une référence, ...). Cette fonction fait partie des 10 fonctions à connaître absolument dans Excel.

Comment utiliser la fonction NB SI ?


La fonction NB.SI d'Excel se compose de 2 arguments

  1. La plage de données contenant le critère recherché

    Il vous suffit de sélectionner l'ensemble des données de la colonne

  2. Le critère à rechercher

    Il peut s'agir soit d'une valeur entrée directement dans la formule, soit d'une référence à une cellule.

=NB.SI(plage de données; critère)

Comment utiliser la fonction NB SI ?

Nous allons partir de ce tableau qui présente les quantités vendues de produit par nos vendeurs

Presentation de la fonction NB.SI Excel

Nous voulons savoir combien de fois nous avons vendu de Kiwi ?

Vous pourriez compter les lignes qui contiennent le mot "Kiwi" mais ça serait bien trop long surtout si vous avez plusieurs centaines de ligne. C'est justement dans cette situation qu'il faut utiliser la fonction NB.SI.

  1. Ecrivez dans une cellule le nom de la fonction =NB.SI(
  2. Puis indiquez la plage de cellules (les références de la colonne) où se trouve le mot Kiwi. Dans notre cas, c'est la colonne B
  3. Enfin, indiquez le critère à rechercher, soit le mot "Kiwi". Le mot est à mettre entre guillemet quand il s'agit de texte.

=NB.SI(B2:B12;"Kiwi") => 4

Fonction NB.SI pour compter le nombre de ligne avec un critere fixe

Vous voyez, c'est tout simple !

Utiliser des références de cellules

Maintenant, nous pouvons encore plus nous simplifier le travail. Plutôt que d'écrire le mot directement dans la formule, nous pouvons utiliser le même mot mais écrit dans une cellule. Par exemple, Je vais écrire le mot "Kiwi" dans la cellule F2 et donc ma formule va s'écrire :

=NB.SI(B2:B12;F2) => 4

Fonction NB.SI en utilisant la reference dune cellule

Remarque : Quand il s'agit de référence à une cellule, il ne faut pas mettre de guillemet.

L'avantage de cette technique c'est qu'il vous suffit de changer le nom du produit à rechercher en F2 pour effectuer un dénombrement sur un autre produit. Comme par exemple en écrivant le mot "Poire"

Modification du nom du critere de denombrement
  • La formule n'a pas été modifiée
  • Seul de critère à dénombrer a été changer en F2
  • Cette fois, nous avons dénombré 3 fois le mot Poire dans notre tableau de produit.

Et comment écrire la fonction NB.SI pour les prénoms?

Si maintenant nous voulons savoir combien de fois le vendeur "Bernard" a effectué de vente, il faut modifier la plage de critère de recherche. Dans ce cas, il faut changer le premier paramètre de la fonction pour indiquer la colonne A.

=NB.SI(A2:A12;F2)

Pour un denombrement sur les prenoms il faut changer la plage de critere

Article liés

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.