RECHERCHEV sur 2 colonnes

RECHERCHEV sur 2 colonnes
Dernière mise à jour le 05/02/2024
Temps de lecture : 2 minutes

Comment faire une Recherche en utilisant 2 colonnes pour constituer la clé de recherche

  1. Ne pas utiliser la fonction RECHERCHEV

    La fonction RECHERCHEV a été construite pour faire une recherche sur UNE SEULE colonne

  2. La fonction RECHERCHEX résout le problème

    La nouvelle fonction de recherche d'Excel, est plus souple dans la construction et permet de faire une recherche sur plusieurs colonnes

Utiliser 2 colonnes pour construire votre identifiant

La fonction RECHERCHEX fait partie des nouvelles fonctions accessibles seulement avec Microsoft 365 et Excel Online. Cette fonction améliore grandement les manquements de la fonction RECHERCHEV. Comme notamment la possibilité de construire une recherche sur 2 colonnes.

Nous allons prendre la situation suivante où nous avons le tableau avec

  • les codes employés
  • les dates de présence et le temps travaillé pour chaque journée.

Nous voulons retourner le temps travaillé sur une journée pour un employé. Donc nous devons nous faire la recherche sur les colonnes Code Employé et Date.

Tableau de données sans identifiant unique 1

Construction de la formule RECHERCHEX pour rechercher sur 2 colonnes

Étape 1 : Construire le premier paramètre avec 2 cellules

Nous allons tout d'abord construire notre identifiant en prenant le contenu des cellules G2 et G3 avec le symbole de concaténation &

=RECHERCHEX(G2&G3;

Le premier paramètre de la fonction RECHERCHEX est constitué de 2 cellules

Étape 2 : Construire le tableau de recherche

C'est ce point qui est le plus important.

En effet, construire la clé à partir de 2 colonnes n'est pas très difficile. Mais il ne faut pas oublier que la recherche doit également se faire sur 2 colonnes. Nous allons donc construire notre "tableau de référence" en concaténant les colonnes C et A

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31

Construction du tableau de recherche avec 2 colonnes

Ici, il faut bien respecter l'ordre de construction de la clé et du tableau de recherche

  • L'ordre de la clé c'est Date + Code Employé
  • La construction du tableau doit aussi respecter le même ordre.
  • D'où l'association des colonnes C et A (dans cet ordre).

La construction du tableau de référence en mémoire n'est possible qu'avec l'interprétation des fonctions matricielles dynamiques. C'est pour cela que cette technique n'est possible qu'avec Microsoft 365.

Étape 3 : Ajouter la colonne à retourner.

Il ne reste plus qu'à indiquer la colonne à retourner et la fonction est terminée ?

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31;$D$2:$D$31)

Ajout de la colonne à retourner par la fonction RECHERCHEX

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MVP_logo_2017

RECHERCHEV sur 2 colonnes

Reading time: 2 minutes
Dernière mise à jour le 05/02/2024

Comment faire une Recherche en utilisant 2 colonnes pour constituer la clé de recherche

  1. Ne pas utiliser la fonction RECHERCHEV

    La fonction RECHERCHEV a été construite pour faire une recherche sur UNE SEULE colonne

  2. La fonction RECHERCHEX résout le problème

    La nouvelle fonction de recherche d'Excel, est plus souple dans la construction et permet de faire une recherche sur plusieurs colonnes

Utiliser 2 colonnes pour construire votre identifiant

La fonction RECHERCHEX fait partie des nouvelles fonctions accessibles seulement avec Microsoft 365 et Excel Online. Cette fonction améliore grandement les manquements de la fonction RECHERCHEV. Comme notamment la possibilité de construire une recherche sur 2 colonnes.

Nous allons prendre la situation suivante où nous avons le tableau avec

  • les codes employés
  • les dates de présence et le temps travaillé pour chaque journée.

Nous voulons retourner le temps travaillé sur une journée pour un employé. Donc nous devons nous faire la recherche sur les colonnes Code Employé et Date.

Tableau de données sans identifiant unique 1

Construction de la formule RECHERCHEX pour rechercher sur 2 colonnes

Étape 1 : Construire le premier paramètre avec 2 cellules

Nous allons tout d'abord construire notre identifiant en prenant le contenu des cellules G2 et G3 avec le symbole de concaténation &

=RECHERCHEX(G2&G3;

Le premier paramètre de la fonction RECHERCHEX est constitué de 2 cellules

Étape 2 : Construire le tableau de recherche

C'est ce point qui est le plus important.

En effet, construire la clé à partir de 2 colonnes n'est pas très difficile. Mais il ne faut pas oublier que la recherche doit également se faire sur 2 colonnes. Nous allons donc construire notre "tableau de référence" en concaténant les colonnes C et A

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31

Construction du tableau de recherche avec 2 colonnes

Ici, il faut bien respecter l'ordre de construction de la clé et du tableau de recherche

  • L'ordre de la clé c'est Date + Code Employé
  • La construction du tableau doit aussi respecter le même ordre.
  • D'où l'association des colonnes C et A (dans cet ordre).

La construction du tableau de référence en mémoire n'est possible qu'avec l'interprétation des fonctions matricielles dynamiques. C'est pour cela que cette technique n'est possible qu'avec Microsoft 365.

Étape 3 : Ajouter la colonne à retourner.

Il ne reste plus qu'à indiquer la colonne à retourner et la fonction est terminée ?

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31;$D$2:$D$31)

Ajout de la colonne à retourner par la fonction RECHERCHEX

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.