Masquer les données sensibles dans Excel

Masquer les données sensibles dans Excel
Dernière mise à jour le 05/02/2024
Temps de lecture : 3 minutes

Vous pouvez masquer les données sensibles d'un classeur en n'affichant que le résultat sous forme d'icône.

C'est quoi des données sensibles ?

Il existe des situations où des données sensibles ne sont pas à afficher mais sans les effacer. Par exemple dans les cas suivants :

  • Les notes des personnes recalées
  • Les revenus des personnes demandeuses d'allocations
  • Les niveaux de toxicités ???
  • ...

Tous ces résultats sont très "sensibles" et n'ont pas à être diffusées. Donc, il peut être préférable de n'afficher que l'icône qui indique si les valeurs rentrent dans les critères ou pas.

Cas d'application : Test positif à l'EPO.

Pour montrer comment masquer les données sensibles, nous allons illustrer la technique en partant d'un tableau de prélèvement des taux d'hématocrite d'athlètes.

Tableau de prélèvements EPO

Étape 1 : Faire une formule pour détecter les cas positifs

Un cas est considéré positif quand au moins l'un des prélèvements dépasse un taux de 50%. Nous allons donc construire un test logique avec la fonction OU.

=OU(B3>50;C3>50;D3>50)

Et ensuite, on insère ce test dans une fonction SI pour afficher le terme "positif" quand le test est VRAI.

=SI(OU(B3>50;C3>50;D3>50);"Positif";"")

Test SI pour retrouver les cas positifs

Étape 2 : Afficher des icônes dans les cellules

Grâce aux mises en forme conditionnelles, vous pouvez afficher des icônes en plus du résultat dans les cellules

Ajout dicônes dans les cellules

Étape 3 : Personnalisation de la règle d'affichage des icônes

Par défaut, les icônes représentent le premier, deuxième et troisième tiers des valeurs. Ici, nous voulons

  • Afficher d'une icône verte, toutes les valeurs inférieures à 50
  • En icône jaune, les valeurs égales à 50
  • D'une icône rouge toutes les valeurs supérieures à 50

Depuis le ruban, sélectionnez le menu Accueil > Mise en forme conditionnelle > Gérer les règles puis Modifier la règle

Menu Gérer les règles
Sélection du jeu dicones de mise en forme conditionnelle

Ensuite on change les paramètres de la règle de la façon suivante

  1. Cliquez sur le bouton Ordre inverse des icônes
  2. Changez le type de Pourcentage à Nombre
  3. Pour la première règle, sélectionnez le symbole supérieur stricte à 50
  4. Pour la seconde règle, sélectionnez le symbole supérieur ou égale à 50
Paramètres daffiche des icônes

Le résultat est maintenant le suivant

Affichage des nombres et icônes

Étape 4 : N'afficher que l'icône ?

Maintenant, vous allez réouvrir le gestion de règles du jeu d'icônes (comme à l'étape 3). Dans la boîte de dialogue, sous le bouton Ordre inverse des icônes, il y a l'option Affichez l'icône uniquement.

Option pour nafficher que les icônes

Au final, nous avons un tableau qui n'affiche pas les données sensibles mais seulement l'icône qui indique les cas positifs

Les données sensibles sont remplacées par des icônes

Articles liés

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MVP_logo_2017

Masquer les données sensibles dans Excel

Reading time: 3 minutes
Dernière mise à jour le 05/02/2024

Vous pouvez masquer les données sensibles d'un classeur en n'affichant que le résultat sous forme d'icône.

C'est quoi des données sensibles ?

Il existe des situations où des données sensibles ne sont pas à afficher mais sans les effacer. Par exemple dans les cas suivants :

  • Les notes des personnes recalées
  • Les revenus des personnes demandeuses d'allocations
  • Les niveaux de toxicités ???
  • ...

Tous ces résultats sont très "sensibles" et n'ont pas à être diffusées. Donc, il peut être préférable de n'afficher que l'icône qui indique si les valeurs rentrent dans les critères ou pas.

Cas d'application : Test positif à l'EPO.

Pour montrer comment masquer les données sensibles, nous allons illustrer la technique en partant d'un tableau de prélèvement des taux d'hématocrite d'athlètes.

Tableau de prélèvements EPO

Étape 1 : Faire une formule pour détecter les cas positifs

Un cas est considéré positif quand au moins l'un des prélèvements dépasse un taux de 50%. Nous allons donc construire un test logique avec la fonction OU.

=OU(B3>50;C3>50;D3>50)

Et ensuite, on insère ce test dans une fonction SI pour afficher le terme "positif" quand le test est VRAI.

=SI(OU(B3>50;C3>50;D3>50);"Positif";"")

Test SI pour retrouver les cas positifs

Étape 2 : Afficher des icônes dans les cellules

Grâce aux mises en forme conditionnelles, vous pouvez afficher des icônes en plus du résultat dans les cellules

Ajout dicônes dans les cellules

Étape 3 : Personnalisation de la règle d'affichage des icônes

Par défaut, les icônes représentent le premier, deuxième et troisième tiers des valeurs. Ici, nous voulons

  • Afficher d'une icône verte, toutes les valeurs inférieures à 50
  • En icône jaune, les valeurs égales à 50
  • D'une icône rouge toutes les valeurs supérieures à 50

Depuis le ruban, sélectionnez le menu Accueil > Mise en forme conditionnelle > Gérer les règles puis Modifier la règle

Menu Gérer les règles
Sélection du jeu dicones de mise en forme conditionnelle

Ensuite on change les paramètres de la règle de la façon suivante

  1. Cliquez sur le bouton Ordre inverse des icônes
  2. Changez le type de Pourcentage à Nombre
  3. Pour la première règle, sélectionnez le symbole supérieur stricte à 50
  4. Pour la seconde règle, sélectionnez le symbole supérieur ou égale à 50
Paramètres daffiche des icônes

Le résultat est maintenant le suivant

Affichage des nombres et icônes

Étape 4 : N'afficher que l'icône ?

Maintenant, vous allez réouvrir le gestion de règles du jeu d'icônes (comme à l'étape 3). Dans la boîte de dialogue, sous le bouton Ordre inverse des icônes, il y a l'option Affichez l'icône uniquement.

Option pour nafficher que les icônes

Au final, nous avons un tableau qui n'affiche pas les données sensibles mais seulement l'icône qui indique les cas positifs

Les données sensibles sont remplacées par des icônes

Articles liés

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.